Staking Pages Currently Inaccessible

Incident Report for The Sandbox Service Health

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 13:24 UTC

Monitoring

Access to staking pages has been restored following a fix. Users can now withdraw their staked SAND.
Posted Jul 01, 2025 - 14:43 UTC

Identified

We’ve identified an issue preventing access to the staking pages and are actively working on a fix.
Posted Jul 01, 2025 - 12:16 UTC
This incident affected: The Sandbox Website (Staking).