Cloudflare disruptions

Incident Report for The Sandbox Service Health

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 14:20 UTC

Update

We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 14:55 UTC

Monitoring

Cloudflare has resolved the issue causing earlier disruptions. Our services are recovering, and we are currently monitoring to ensure full stability. Thank you for your patience.
Posted Nov 18, 2025 - 14:55 UTC

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 14:13 UTC

Investigating

We are currently experiencing service disruptions due to a widespread Cloudflare outage. Our team is monitoring the situation and will provide updates as soon as services begin to recover. Thank you for your patience.
Posted Nov 18, 2025 - 14:11 UTC
This incident affected: The Sandbox Website (Homepage, Authentication, API, User profile, Assets inventory, Assets search, Asset info, Assets, Avatars info, Collections, Experience info, Estates, Lands, Lands search, User events, Social events, Claim assets, Staking).