Issue with our DNS provider

Incident Report for The Sandbox Service Health

Resolved

This incident has been resolved.
Posted Sep 14, 2023 - 17:07 UTC

Update

The incident has been resolved.
Posted Sep 14, 2023 - 16:29 UTC

Investigating

Our DNS provider is currently experiencing an issue which is causing users from specific regions to be unable to reach our servers. We will update here as soon as we receive additional information from our provider.
Posted Sep 14, 2023 - 14:43 UTC