Game Launcher Issue preventing Game Client Installation
Incident Report for The Sandbox Status Page
Resolved
Our third-party provider confirmed that the issue was resolved early this morning at approximately 04:00 AM (UTC). Our Game QA team has thoroughly tested the Game Client launcher, since then, and it is now functioning properly.
You can find further details on our Launcher patch update here: https://www.sandbox.game/en/game/changelog/
Posted May 31, 2024 - 12:04 UTC
Identified
We have identified an issue with our Game Client Launcher that is currently preventing proper installation. Our team is in communication with the service provider responsible for this component, who is experiencing technical hosting difficulties.

We sincerely apologize for any inconvenience this may cause and appreciate your patience as we work to resolve this issue.
Posted May 30, 2024 - 18:06 UTC
This incident affected: Game Client / Experiences.